Operation Library

Some steps that are necessary when assembling a product do not involve the simultaneous addition of a part or subassembly. In DFA, these steps are called separate operations and are added to an analysis from the program’s operation library. This operation library is completely customizable. Any of your custom operations can be added to the library and then later used in your analyses.

This tutorial first describes how to use in an analysis an existing operation to estimate the process time and process cost for the application of thread locking compound to two screws. The second section of this tutorial shows how to view the formula for the Apply adhesive drops operation that was used in the first section of this tutorial. Some of the more important aspects of the formula and the operation formula window are also described. The third section of this chapter shows how to create within the operations library a new operation for automatic robotic welding.

Using an operation in an analysis

Open the analysis file for the Pneumatic control that has been installed with your DFA software. Select Open from the File menu, browse to DFMA\data\samples, and double click the pneumatic control.dfax analysis file. After the file opens, click the Original design - completed analysis tab.

The product in this analysis is the small pneumatic control pictured below:

In this tutorial, we will add to this analysis an operation for applying thread locking compound to the two screws that hold the cover in place.

Click the Screws entry that is listed on the Structure chart.

Click Operation on the Insert menu or click the button on the toolbar. In the Insert Operation dialog that appears, expand the Adhesive application category by clicking the that appears to the left of the category on the operation library tree. Click the Apply adhesive drops operation and click the Insert button to insert the operation into the analysis at the end of the Process chart. Click the Close button on the Insert Operation dialog to close the dialog.

Click twice on the name of the Apply adhesive drops operation on the Process Chart and change its name to Apply thread locking compound.

On the questions panel for the operation, accept the default value of 2.9 s for the Tool acquisition time input and also accept the default value of low < 50,000 centipoise from the Viscosity of adhesive dropdown.

Three drops of thread locking compound will be applied to each of the two screws, so change the Drops per location input to 3 and the Repeat count input to 2. Notice in the status bar at the bottom of the screen, the program has estimated a process time of 6.3 s to acquire the applicator, apply the thread locking compound to each of the two screws, and then set aside the applicator. At the assembly labor rate of 40 $/hr and the 85 percent plant efficiency specified in the analysis of the pneumatic control, that results in a process cost of $0.08.
Open the Operation Library by selecting Operations from the Libraries menu at the top of your program screen.

When the Operation Library opens, if necessary, expand the Adhesive operations category by clicking the that appears to the left of the category name on the library tree.

Click the Apply adhesive drops operation to select it. The library window is divided into two panes; the library tree on the left, which lists the categories and operations, and the operation pane on the right. In the Operation pane, the formula status indicates if the formula entered for the operation is valid or contains syntax errors. The formula status will also indicate if no formula has been entered for the operation. The information defined in the details and picture boxes will appear alongside the operation question panel inputs after the operation is added to an analysis.

Click the Edit formula button to open the Operation Formula window. Maximize the window so it fills your computer’s screen. Click the expander that appears in the upper right corner of the formula window to display the Test View Panel. Click Calculate to populate the Test View Panel.

The Operation Formula window is divided into three areas. The Formula Panel is the white edit box that appears on the top of the window. The Variables Listing appears on the bottom portion of the window. The Test View Panel appears on the right.

The Formula Panel contains the formula which is used to estimate the Process time and Process cost for the operation. The syntax used to write formulas is based on a subset of the C programming language and details on writing expressions are available in software’s help topic C-Like formula syntax.

Interpretation and understanding of the operation formula is done in combination with the Variables Listing and the Test View Panel. The first three rows of this formula are a set of conditional statements that set the value of the Basic_unit_time variable based on the selection made in the Viscosity_of_adhesive dropdown list. The first row sets the Basic_unit_time variable to a value of 1.0s. The second row changes that value to 1.5s when the Viscosity_of_adhesive dropdown list is set to its second selection. The third row changes the value of the Basic_unit_time variable to 2.0s when the Viscosity_of_adhesive dropdown list is set to its third selection. The fifth and sixth rows of the formula calculate the time and cost results for the operation using the Process_time_per_entry and the Process_cost_per_entry program variables.

Program variables are special variables that are used in the operation formula to interact with the rest of the software program. For example, when this Apply adhesive drops operation is added to an analysis, the program will use the value assigned to the Process_time_per_entry program variable as the process time result for the operation. This value will appear in the program’s status bar and be included in the total process time roll-up for the analysis. Click Program Variable... from the Insert menu to display a listing of all available program variables. Some program variables are output variables and some are input variables.
Output variables take their assigned values from the operation formula and pass them back to the main program. Input variables take values from the main program and pass them into the operation formula for use in formula calculations. The output program variables each correspond to a result at the bottom of the test view panel and are:

- Repeat_count
- Process_time_per_entry
- Process_cost_per_entry
- Assembly_tool_or_fixture_cost
- Weight

The input program variables are:

- Assembly_labor_rate
- Assembly_length
- Assembly_depth
- Assembly_width
- Life_volume
- Plant_efficiency
- Tool_acquisition_time

Click the Close button on the bottom of the Program variables window to return to the Operation formula window.

The variables that appear in the Variables Listing are automatically generated by the program based on the variables defined in the operation’s formula. The order of the listed rows determines the order in which inputs are displayed on the questions panel after the operation is added to an analysis. Many of the columns are editable so that various characteristics of each variable can be defined. The column definitions are:

- **Variable Name** - The name of the row’s variable used in the formula. Variable names must use underscores instead of spaces.

- **Questions Panel Label** - The text label for the input that will be used on the questions panel when the operation is added to an analysis. This column defaults to the same value as the Variable Name but with underscores replaced by spaces.

- **Type** - Identifies how the input will appear on the questions panel after the operation is added to an analysis.

- **Show to User?** - Indicates whether or not the input will be shown on the questions panel after the operation is added to an analysis.

- **Condition** - Contains the name of the checkbox variable that is true when the input should be displayed on the questions panel after the operation is added to an analysis. This column is only available for editing when the Show to user? column is set to Sometimes.

- **User Can Edit?** - Indicates whether or not the input can be changed on the questions panel after the operation is added to an analysis.

- **Value** - The value currently stored for the row’s variable. This can be a constant value that you type into the column or the result of a calculation done using the operation’s formula.

- **Number of Decimals** - The number of decimal places that will be shown on the questions panel after the operation is added to an analysis.

- The next columns define the English and metric units as well as the conversion factor used to convert between English and metric units.

- **Description** - The text that is displayed in a pop-up when help is requested for the input after the operation is added to an analysis.
Creating a new operation

One improvement made to the present version of DFA is the ability to use, with separate operations, process rates that are different than the labor rate specified for the main assembly. This makes it much easier to add and use operations that utilize a high level of automation to reduce their hourly process rate. To illustrate this improvement, we’ll be creating a new operation for Robotic MIG welding.

On the operations library tree, expand the *Welding* category by clicking the that appears to the left of the category name and then click the last operation in the category, *Manual MIG/TIG Vbutt weld*, to highlight it. Click *Operation* from the Insert menu to add a new operation and then name it *Robotic MIG Weld*. Click the *Edit formula* button to open the Operation Formula Window and then, if necessary, maximize the window so it fills your computer’s screen. Be sure that *English* is checked on the *Units* menu so that you develop the operation using English units.

Into the Formula Panel, enter the following formula text:

```
Welding_speed = Material == 1 ? 13.6 : 24.2;
Material_cost_per_length = Material == 1 ? 0.035 : 0.028;
Weight = Material == 1 ? Length_of_welds * 0.0014 : Length_of_welds * 0.0005;
Welding_time = Length_of_welds / Welding_speed * 60 + (Number_of_welds + 1) * 0.8;
Process_time_per_entry = (Time_to_start_machine + Welding_time);
Assembly_tool_or_fixture_cost;
Material_cost = Include_material_cost ? Material_cost_per_length * Length_of_welds : 0;
Process_cost_per_entry = (Time_to_start_machine / 3600 * (Operator_rate + Machine_rate) + Welding_time / 3600 * Machine_rate) / (Plant_efficiency/100) + Material_cost;
```

Click the expander that appears in the upper right corner of the formula window to display the Test View Panel. Click *Calculate* to populate the Variables Listing and the Test View Panel.

Click the row number to the left of Row 1 on the Variables Listing and select *Group* from the *Insert* menu to insert an input group box. Replace the *Group* title name that appears by default in the Questions Panel Label column with the name *Welding data*.

Insert two more groups into the Variables listing, one onto row 2 and another onto row 3. Name one group *Machine data* and the other group *Results*.

Variable rows can be moved by clicking a row number and then dragging and dropping the row into another location on the Variables Listing. Move the variable rows into the questions panel display order that is shown below.
Click Calculate and note on the Test View Panel that the questions panel display has been updated to reflect the new order of variables.

Change the Type column for the Material variable to List because this input will be shown on the questions panel as a dropdown list. Click the button that appears in the Value column to display the List Contents window where each selection available in the dropdown list will be defined. On the first line of the List Contents window, type the text Steel and press Enter. On the second line type Aluminum and be sure that there are no empty lines defined below.

Click OK to return to the Operation Formula window. Type the text Select base material welded into the Description column for the Material variable.

Complete the rest of the variable rows as shown below:

Click Calculate and note that the Test View Panel appears as shown below.
On the Test View Panel, click the **Material** dropdown and note that there are selections available for Steel and Aluminum. Select **Aluminum** and note that the default values for the **Welding Speed** and the **Material cost per length** inputs both change to reflect the values defined in the operation formula for Aluminum. Also note that the results for the operation change to reflect the change in material.

Uncheck the **Include material cost** checkbox and note that the **Material cost per length** input and the **Material cost** result disappear from the Test View Panel as defined in the display conditions for the two variables. Also note that the **Process cost**
result for the operation no longer includes the cost of material, as defined in the operation formula.

Click OK to close the operation formula window and return to the main library screen. Close the library and return to the main program screen by clicking Exit on the File menu. Click Yes when the program asks if you want to save changes.

On the main program screen, insert the operation onto the Structure Chart. Click Operation on the Insert menu or click the button on the toolbar. In the Insert Operation dialog that appears, expand the Welding category by clicking the ▼ that appears to the left of the category on the operation library tree. Click the Robotic MIG weld operation and click the Insert button to insert the operation onto the Structure Chart. Close the Insert Operation dialog.

On the questions panel for the operation, change the Material dropdown from Steel to Aluminum and note that the default values and results change as they did on the Test View Panel when the operation was developed. Also, uncheck the Include material cost checkbox and note the questions panel behaves as it did on the Test View Panel. Press F1 on your keyboard to request help on the Include material cost checkbox and note a pop-up appears that contains the description for the Include_material_cost variable.