Develop a User Process

Introduction

The User process program allows you to install into the DFM Concurrent Costing software your own cost model for a manufacturing process. For this tutorial, an imaginary process named “Forming” will be added which has three operations, namely:

1. Preheating the workpiece.
2. Forming the workpiece to the desired shape.
3. Trimming the workpiece to produce the part.

Preheating the workpiece is optional and the user can select automatic or manual trimming of the part.

Appearance and functionality of the completed Forming process

1. When the user starts the Forming analysis, the usual initial responses are made including the life volume, part envelope shape selection, part overall dimensions, and the direction of forming.

2. The user clicks Select process and material to display the process and material selection dialog. The User processes category available at the bottom of the process listing is opened and the Forming process is selected. The Aluminum alloy material category is opened and Duralumin is selected.

3. The screen for the Forming process is displayed and a default cost estimate for the described part is generated immediately. The default Process chart appears on the left while the Main response panel for the Forming process appears on the right.
4. The user refines the default cost estimate for the part by adjusting inputs on the Main response panel. The user clicks the button alongside the *Part volume* field to display the Volume geometry calculator, which would be used to define a value for the Part volume field. A similar calculator would also be used to define a value for the Part projected area field.

5. Preheating is not required for this Duralumin material so the *Preheating required* checkbox is unchecked. After *Calculate* is clicked, the Preheat workpiece operation is automatically removed from the Process chart.

6. Automatic trimming will be used for this part so the user changes the *Type of trimming* dropdown to *Auto* and clicks *Calculate*. The trimming operation is automatically changed to an auto trim operation.

7. Analysis of this part is now complete and the results can be presented in the software’s reports and graphs.

**Add the Forming process and associated operations to the Process library**

1. Select *User Process* from the *Libraries* menu.

2. Choose *Process* from the *Insert* menu. A new user process is added to the library with its name in edit mode. Name the process *Forming* and press the *Enter* key to accept the name.

3. Click on the *Items not yet added* entry beneath the Forming process and select *Operation* from the Insert menu. A new operation is added with its name in edit mode. Type *preheat workpiece* and press the *Enter* key.

4. Insert two more operations under the Preheat workpiece operation. Name them *form workpiece* and *auto trim part*.
Define materials that are applicable to the Forming process

1. Click on the *Forming* process to display the Material code names box on the right.

2. Into the Material code names box, type **AL1100** and press the **Enter** key to begin a new line. On the new line, type **AL5050** and press the **Enter** key to begin a third line. On the third line, type **Duralumin** and do not press the Enter key.

![Material code names](image)

Define the process level formulas

1. Open the process level Formula window by selecting *Formula* from the *Edit* menu.

2. Before entering formulas, be sure *English* is checked in the *Units* menu.

3. In the top panel of the window, enter the following expressions.

   ```plaintext
   Raw_material_cost = 1.25;
   Raw_material_cost = Material_code_name == 2 ? 1.58 : Raw_material_cost;
   Raw_material_cost = Material_code_name == 3 ? 2.29 : Raw_material_cost;
   Material_scrap_value = 0.15;
   Material_scrap_value = Material_code_name == 2 ? 0.19 : Material_scrap_value;
   Material_scrap_value = Material_code_name == 3 ? 0.28 : Material_scrap_value;
   Material_density = 0.097;
   Material_density = Material_code_name == 2 ? 0.094 : Material_density;
   Material_density = Material_code_name == 3 ? 0.090 : Material_density;
   Forming_pressure = 100;
   Forming_pressure = Material_code_name == 2 ? 150 : Forming_pressure;
   Forming_pressure = Material_code_name == 3 ? 200 : Forming_pressure;
   Batch_size = Life_volume / 8;
   Extra_material_factor;
   Overall_plant_efficiency;
   Part_weight = Part_volume * Material_density;
   Part_projected_area;
   Preheating_required;
   Type_of_trimming;
   4. Click **Calculate** to display the list of variables in the bottom panel of the window.

---

*Boothroyd Dewhurst, Inc.*
Define the Main response panel

1. Some variables are to be displayed on the Main response panel. These are listed below. Drag and drop these variables within the variables listing so that they are in the order shown and are at the top of the list.

   - Batch_size
   - Overall_plant_efficiency
   - Raw_material_cost
   - Material_scrap_value
   - Part_volume
   - Part_projected_area
   - Preheating_required
   - Type_of_trimming

2. For all the remaining variables change Always to Never in the Show to user? column.

3. Make the following change for the Part_volume variable.
   - Calculator type - change from None to Volume

4. Make the following change for the Part_projected_area variable.
   - Calculator type - change from None to Projected area

5. Make the following changes for the Preheating_required variable.
   - Type - change Number to Checkbox.

6. Make the following changes for the Type_of_trimming variable.
   - Type - change Number to List
     - Value - click the button to display the List Contents dialog. Type Auto and press Enter to start a new line. On the new line type Manual and do not press Enter. Click OK to close the dialog.

7. To complete the variables list, enter the values, units, conversion factors and descriptions shown below.
8. Click OK to exit the process level Formula window and return to the Process library.

**Define the operation formula for the preheat workpiece operation**

1. Double click the *preheat workpiece* operation to open the Formula window for that operation.

2. In the top panel of the window, enter the following expressions.

   \[
   \text{Material\_weight} = \text{Part\_weight} \times \text{Extra\_material\_factor} ;
   \]
   \[
   \text{Heating\_cost} = \text{Material\_weight} \times \text{Heating\_cost\_per\_unit\_weight} ;
   \]
   \[
   \text{Process\_cost} = \left( \frac{\text{Time\_to\_load\_and\_unload} \times \text{Heating\_process\_rate}}{3600} + \text{Heating\_cost} \right) \times \frac{1}{\text{Overall\_plant\_efficiency} / 100} ;
   \]
   \[
   \text{Setup\_cost} = \text{Setup\_rate} \times \frac{\text{Setup\_time}}{\text{Batch\_size}} ;
   \]

3. Click **Calculate** to display the list of variables in the bottom panel of the window.

**Define the operation response panel for the preheat workpiece operation**

1. Drag and drop the following variables which will be displayed to the user so that they are in the order shown and are at the top of the variables listing.

   - *Setup\_rate*
   - *Setup\_time*
   - *Heating\_process\_rate*
   - *Time\_to\_load\_and\_unload*
   - *Heating\_cost\_per\_unit\_weight*

2. For all the remaining variables change **Always** to **Never** in the **Show to user?** column.

3. To complete the variables list, enter the values, units, conversion factors and descriptions shown below.
4. Click OK to close the Formula window.

**Define the operation formula for the form workpiece operation**

1. Double click the form workpiece operation to open the Formula window for that operation.

2. In the top panel of the window, enter the following expressions.
   
   \[
   \begin{align*}
   \text{Material\_weight} &= \text{Part\_weight} \times \text{Extra\_material\_factor}; \\
   \text{Material\_cost} &= \text{Material\_weight} \times \text{Raw\_material\_cost}; \\
   \text{Forming\_force} &= \text{Forming\_pressure} \times \text{Part\_projected\_area}; \\
   \text{Time\_per\_part\_for\_forming} &= \text{Part\_depth} / \text{Forming\_force} \times \text{Forming\_time\_constant}; \\
   \text{Process\_cost} &= ((\text{Time\_to\_load\_and\_unload} + \text{Time\_per\_part\_for\_forming}) \times \text{Forming\_process\_rate}) / 3600 / (\text{Overall\_plant\_efficiency} / 100); \\
   \text{Tooling\_cost\_per\_part} &= \text{Initial\_tooling\_investment} / \text{Life\_volume};
   \end{align*}
   \]

3. Click Calculate to display the list of variables in the bottom panel of the window.

**Define the operation response panel for the form workpiece operation**

1. Drag and drop the following variables which will be displayed to the user so that they are in the order shown and are at the top of the variables listing.

   \[
   \begin{align*}
   \text{Forming\_process\_rate} \\
   \text{Time\_to\_load\_and\_unload} \\
   \text{Time\_per\_part\_for\_forming} \\
   \text{Initial\_tooling\_investment}
   \end{align*}
   \]

2. For all the remaining variables change Always to Never in the Show to user? column.
3. To complete the variables list, enter the values, units, conversion factors and descriptions shown below.

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Value</th>
<th>Number of decimals</th>
<th>English Unit (E)</th>
<th>Metric Unit (M)</th>
<th>Conversion Factor (F)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Forming_process_rate</td>
<td>60.000</td>
<td>3</td>
<td>$/hr</td>
<td>/hr</td>
<td>1</td>
<td>burdened process rate for the forming machine and operator</td>
</tr>
<tr>
<td>Time_to_load_andUnload</td>
<td>6.000</td>
<td>3</td>
<td>s</td>
<td>s</td>
<td>1</td>
<td>time to load and unload workpiece for forming</td>
</tr>
<tr>
<td>Time_per_part_for-forming</td>
<td>50.000</td>
<td>3</td>
<td>s</td>
<td>s</td>
<td>1</td>
<td>time to form the workpiece</td>
</tr>
<tr>
<td>Initial_tooling_invest</td>
<td>1,000</td>
<td>$</td>
<td>$</td>
<td>$</td>
<td>1</td>
<td>cost of initial purchase of dies, molds, tools or fixtures; does</td>
</tr>
<tr>
<td>Material_weight</td>
<td>0.12</td>
<td>lb</td>
<td>kg</td>
<td></td>
<td>0.4536</td>
<td>weight of material in the workpiece after this operation - use</td>
</tr>
<tr>
<td>Part_weight</td>
<td>0.097</td>
<td>lb</td>
<td>kg</td>
<td></td>
<td>0.4536</td>
<td>weight of the finished part</td>
</tr>
<tr>
<td>Extra_material_factor</td>
<td>1.200</td>
<td>$</td>
<td></td>
<td>$</td>
<td>1</td>
<td>factor to account for the extra material to be trimmed</td>
</tr>
<tr>
<td>Material_cost</td>
<td>0.1455</td>
<td>$</td>
<td>$</td>
<td>$</td>
<td>1</td>
<td>material cost per part, reduced where appropriate through re</td>
</tr>
<tr>
<td>Raw_material_cost</td>
<td>1.250</td>
<td>$/lb</td>
<td>$/kg</td>
<td></td>
<td>2.20462</td>
<td>cost per unit weight of raw material</td>
</tr>
<tr>
<td>Forming_force</td>
<td>100.00</td>
<td>lb</td>
<td>N</td>
<td></td>
<td>4.44819</td>
<td>force required for forming</td>
</tr>
<tr>
<td>Forming_pressure</td>
<td>100.00</td>
<td>lb/in²</td>
<td>MPa</td>
<td></td>
<td>1</td>
<td>pressure required during forming</td>
</tr>
<tr>
<td>Part_projected_area</td>
<td>1.00</td>
<td>in²</td>
<td>cm²</td>
<td></td>
<td>6.4516</td>
<td>projected area of the part</td>
</tr>
<tr>
<td>Part_depth</td>
<td>1.000</td>
<td>in.</td>
<td>mm</td>
<td></td>
<td>25.4</td>
<td>depth of the rectangular part envelope measured in the form</td>
</tr>
<tr>
<td>Forming_time_constant</td>
<td>5,000.00</td>
<td>slb/in</td>
<td>SN/mm</td>
<td></td>
<td>0.17513</td>
<td>constant used to calculate forming time</td>
</tr>
<tr>
<td>Process_cost</td>
<td>0.9333</td>
<td>%</td>
<td>%</td>
<td></td>
<td>1</td>
<td>sum of all processing costs for one part, adjusted for plant eff</td>
</tr>
<tr>
<td>Overall_plant_efficiency</td>
<td>100.0</td>
<td>%</td>
<td>%</td>
<td></td>
<td></td>
<td>average efficiency of all plant operations; equals machine run</td>
</tr>
<tr>
<td>Tooling_cost_per_part</td>
<td>1,000.00</td>
<td>lb</td>
<td>N</td>
<td></td>
<td>1</td>
<td>total cost of dies or molds, tools and fixtures divided by life v</td>
</tr>
<tr>
<td>Life_volume</td>
<td>1,000.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>total number of parts to be produced</td>
</tr>
</tbody>
</table>

4. Click **OK** to close the Formula window.

**Define the operation formula for the auto trim part operation**

1. Double click the *auto trim part* operation to open the Formula window for that operation.
2. In the top panel of the window, enter the following expressions.

   \[
   \text{Material\_weight} = \text{Part\_weight}; \\
   \text{Process\_cost} = \text{Trim\_time} \times \text{Trim\_process\_rate} / 3600 \times \left( \frac{\text{Overall\_plant\_efficiency}}{100} \right); \\
   \]

3. Click **Calculate** to display the list of variables in the bottom panel of the window.

**Define the operation response panel for the auto trim part operation**

1. Drag and drop the following variables which will be displayed to the user within the variables listing in the bottom panel of the Formula window so that they are in the order shown at the top of the list.
   - Trim_process_rate
   - Trim_time
2. For all the remaining variables change **Always to Never** in the **Show to user?** column.
3. To complete the variables list, enter the values, units, conversion factors and descriptions shown below.

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Value</th>
<th>Number of decimals</th>
<th>English Unit (E)</th>
<th>Metric Unit (M)</th>
<th>Conversion Factor (F)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trim_process_rate</td>
<td>50.000</td>
<td>3</td>
<td>$/hr</td>
<td>$/hr</td>
<td>1</td>
<td>burdened process rate for machine and operator</td>
</tr>
<tr>
<td>Trim_time</td>
<td>4.000</td>
<td>3</td>
<td>$/hr</td>
<td>$/hr</td>
<td>1</td>
<td>time for trimming</td>
</tr>
<tr>
<td>Material_weight</td>
<td>0.10</td>
<td>3</td>
<td>lb</td>
<td>kg</td>
<td>0.4536</td>
<td>weight of material in the workpiece after this op</td>
</tr>
<tr>
<td>Part_weight</td>
<td>0.097</td>
<td>3</td>
<td>lb</td>
<td>kg</td>
<td>0.4536</td>
<td>weight of the finished part</td>
</tr>
<tr>
<td>Process_cost</td>
<td>0.0556</td>
<td>3</td>
<td>$</td>
<td>$</td>
<td>1</td>
<td>sum of all processing costs for one part, adjusted</td>
</tr>
<tr>
<td>Overall_plant_efficiency</td>
<td>100.0</td>
<td>3</td>
<td>%</td>
<td>%</td>
<td>1</td>
<td>average efficiency of all plant operations; equals</td>
</tr>
</tbody>
</table>

4. Click OK to close the Formula window.

**Define the manual trim part operation**

1. Copy the *auto trim part* operation by selecting *Copy* from the *Edit* menu. Paste the operation by selecting *Paste* from the *Edit* menu.

2. Rename the second auto trim operation to *manual trim part* by right clicking the operation and selecting *Rename*.

**Define the operation formula and response panel for the manual trim part operation**

1. Double click the *manual trim part* operation to open the Formula window for that operation.

2. Change the *Value* column for the *Trim_process_rate* variable from 50 to 30.

3. Change the *Value* column for the *Trim_time* variable from 4 to 6.

4. Click OK to close the Formula window

**Define display conditions and reject rate defaults for operations**

1. Click on the *preheat workpiece* operation beneath the Forming process and select *Sometimes* from the *Display operation* dropdown.

2. Click the button near the *Condition* field.

3. During an analysis, the preheat workpiece operation will be displayed on the Process chart whenever the *Preheating_required* checkbox is checked on the Main response panel. For this reason, highlight *Preheating_required* on the left and type 1 into the *Value* field on the right.

4. Click OK and highlight the *auto trim part* operation. Click the *Display reject field* checkbox that appears on the right. Enter 0.5 into the *Default value for rejects* field.

5. Select *Sometimes* from the *Display operation* dropdown and click the button near the *Condition* field.

6. During an analysis, the *auto trim part* will be displayed on the Process chart whenever *auto* is selected from the *Type_of_trimming* list on the Main response panel. For this reason, highlight *Type_of_trimming* on the left and type 1 into the *Value* field on the right. Click OK to exit the display conditions window.

7. Highlight the *manual trim part* operation and perform the same steps except enter 2 into the *Value* field when defining the display conditions.
8. Close the Process library by choosing Exit from the File menu.

**Link the material library with the Forming process**

1. From the main window of DFM Concurrent Costing, choose Material from the Libraries menu.
2. Expand the Aluminum alloy category.
3. Highlight the AL1100 aluminum, annealed material and click the Forming checkbox that appears on the right.
4. Click the Forming entry that appears beneath the AL1100 aluminum, annealed material and choose AL1100 from the Material code name dropdown on the right.
5. Highlight the AL5050 aluminum, annealed material and click the Forming checkbox that appears on the right. Click the Forming entry that appears beneath the material and choose AL5050 from the Material code name dropdown on the right.
6. Highlight the AL7075 aluminum, heat treated (T6) material. Choose Material from the Insert menu and a new material is added to the library with its name in edit mode. Name the material Duralumin and press the Enter key to accept the name.
7. Click the Forming checkbox on the right and highlight the Forming entry that appears beneath the material. Choose Duralumin from the Material code name dropdown on the right.

8. Close the Material library by choosing Exit from the File menu.

**Removing the imaginary Forming process**

1. The Forming process added during this tutorial is completely imaginary and should not be used to analyze real formed parts. For this reason, the Forming process should be removed from the Process library after the process is created. Open the User Process library by choosing it from the Libraries menu on the main screen of the software.
2. Highlight the Forming process and select Delete from the Edit menu. Click OK in the Confirm dialog that appears.
3. Close the User Process library by choosing Exit from the File menu.
4. Open the Material library by choosing it from the Libraries menu.
5. Expand the Aluminum alloy material category and highlight the Duralumin material. Select Delete from the Edit menu and click OK in the Confirm dialog that appears.
6. Close the Material library by choosing Exit from the File menu.