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Develop a  User Process
Introduction
The User process program allows you to install into the DFM Concurrent Cos� ng so� ware your own cost model for a 
manufacturing process. For this tutorial, an imaginary process named “Forming” will be added which has three opera� ons, 
namely:

1. Prehea� ng the workpiece.

2. Forming the workpiece to the desired shape.

3. Trimming the workpiece to produce the part.
Prehea� ng the workpiece is op� onal and the user can select automa� c or manual trimming of the part.

Appearance and functionality of the completed Forming process
1. When the user starts the Forming analysis, the usual ini� al responses are made including the life volume, part envelope 

shape selec� on, part overall dimensions, and the direc� on of forming.

2. The user clicks Select process and material to display the process and material selec� on dialog. The User processes 
category available at the bo� om of the process lis� ng is opened and the Forming process is selected. The Aluminum alloy 
material category is opened and Duralumin is selected.

3. The screen for the Forming process is displayed and a default cost es� mate for the described part is generated immediately. 
The default Process chart appears on the le�  while the Main response panel for the Forming process appears on the right.
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4. The user refines the default cost es�mate for the part by adjus�ng inputs on the Main response panel. The user clicks the 

 bu�on alongside the Part volume field to display the Volume geometry calculator, which would be used to define a 
value for the Part volume field. A similar calculator would also be used to define a value for the Part projected area field.

5. Prehea�ng is not required for this Duralumin material so the Prehea�ng required checkbox is unchecked. A�er Calculate is 
clicked, the Preheat workpiece opera�on is automa�cally removed from the Process chart.

6. Automa�c trimming will be used for this part so the user changes the Type of trimming dropdown to Auto and clicks 
Calculate. The trimming opera�on is automa�cally changed to an auto trim opera�on.

7. Analysis of this part is now complete and the results can be presented in the so�ware’s reports and graphs.

Add the Forming process and associated operations to the Process library
1. Select User Process from the Libraries menu.

2. Choose Process from the Insert menu. A new user process is added to the library with its name in edit mode. Name the 
process Forming and press the Enter key to accept the name.

3. Click on the Items not yet added entry beneath the Forming process and select Opera�on from the Insert menu. A new 
opera�on is added with its name in edit mode. Type preheat workpiece and press the Enter key.

4. Insert two more opera�ons under the Preheat workpiece opera�on.  Name them form workpiece and auto trim part
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De�ine materials that are applicable to the Forming process
1. Click on the Forming process to display the Material code names box on the right.  

2. Into the Material code names box, type AL1100 and press the Enter key to begin a new line. On the new line, type AL5050 
and press the Enter key to begin a third line. On the third line, type Duralumin and do not press the Enter key.

De�ine the process level formulas
1. Open the process level Formula window by selec�ng Formula from the Edit menu.

2. Before entering formulas, be sure English is checked in the Units menu. 

3. In the top panel of the window, enter the following expressions.

Raw_material_cost = 1.25;

Raw_material_cost = Material_code_name == 2 ? 1.58 : Raw_material_cost;

Raw_material_cost = Material_code_name == 3 ? 2.29 : Raw_material_cost;

 

Material_scrap_value = 0.15;

Material_scrap_value = Material_code_name == 2 ? 0.19 : Material_scrap_value;

Material_scrap_value = Material_code_name == 3 ? 0.28 : Material_scrap_value;

Material_density = 0.097;

Material_density = Material_code_name == 2 ? 0.094 : Material_density;

Material_density = Material_code_name == 3 ? 0.090 : Material_density;

Forming_pressure = 100;

Forming_pressure = Material_code_name == 2 ? 150 : Forming_pressure ;

Forming_pressure = Material_code_name == 3 ? 200 : Forming_pressure ;

Batch_size=Life_volume / 8;

Extra_material_factor;

Overall_plant_efficiency;

Part_weight = Part_volume * Material_density;

Part_projected_area;

Prehea�ng_required; 

Type_of_trimming;
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4. Click Calculate to display the list of variables in the bo�om panel of the window.

De�ine the Main response panel
1. Some variables are to be displayed on the Main response panel. These are listed below. Drag and drop these variables 

within the variables lis�ng so that they are in the order shown and are at the top of the list.

Batch_size

Overall_plant_efficiency

Raw_material_cost

Material_scrap_value

Part_volume

Part_projected_area

Prehea�ng_required

Type_of_trimming

2. For all the remaining variables change Always to Never in the Show to user? column.

3. Make the following change for the Part_volume variable.

Calculator type - change from None to Volume 

4. Make the following change for the Part_projected_area variable.

Calculator type - change from None to Projected area

5. Make the following changes for the Prehea�ng_required variable.

Type - change Number to Checkbox.

6. Make the following changes for the Type_of_trimming variable.

Type - change Number to List

Value - click the bu�on to display the List Contents dialog. Type Auto and press Enter to start a new line. On the new line 
type Manual and do not press Enter. Click OK to close the dialog.

 7. To complete the variables list, enter the values, units, conversion factors and descrip�ons shown below.
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 8. Click OK to exit the process level Formula window and return to the Process library.

De�ine the operation formula for the preheat workpiece operation
1. Double click the preheat workpiece opera� on to open the Formula window for that opera� on.

2. In the top panel of the window, enter the following expressions.

Material_weight = Part_weight * Extra_material_factor ;

Hea� ng_cost = Material_weight * Hea� ng_cost_per_unit_weight;
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Process_cost = (Time_to_load_and_unload * Hea� ng_process_rate / 3600 + Hea� ng_cost) /(Overall_plant_effi  ciency / 
100);

Setup_cost = Setup_rate*Setup_� me/Batch_size;

3. Click Calculate to display the list of variables in the bo� om panel of the window.

De�ine the operation response panel for the preheat workpiece operation
1. Drag and drop the following variables which will be displayed to the user so that they are in the order shown and are at the 

top of the variables lis� ng.

Setup_rate

Setup_� me

Hea� ng_process_rate

Time_to_load_and_unload

Hea� ng_cost_per_unit_weight

2. For all the remaining variables change Always to Never in the Show to user? column.

3. To complete the variables list, enter the values, units, conversion factors and descrip� ons shown below.

4. Click OK to close the Formula window.

De�ine the operation formula for the form workpiece operation
1. Double click the form workpiece opera� on to open the Formula window for that opera� on.

2. In the top panel of the window, enter the following expressions.

Material_weight = Part_weight * Extra_material_factor;

Material_cost = Material_weight * Raw_material_cost;

Forming_force = Forming_pressure * Part_projected_area;
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Time_per_part_for_forming=Part_depth/Forming_force*Forming_� me_constant;

Process_cost = ((Time_to_load_and_unload + Time_per_part_for_forming) * Forming_process_rate)

 / 3600 / (Overall_plant_effi  ciency / 100);

Tooling_cost_per_part=Ini� al_tooling_investment/Life_volume;

3. Click Calculate to display the list of variables in the bo� om panel of the window.

De�ine the operation response panel for the form workpiece operation
1. Drag and drop the following variables which will be displayed to the user so that they are in the order shown and are at the 

top of the variables lis� ng.

Forming_process_rate 

Time_to_load_and_unload 

Time_per_part_for_forming

Ini� al_tooling_investment

2. For all the remaining variables change Always to Never in the Show to user? column.

3. To complete the variables list, enter the values, units, conversion factors and descrip� ons shown below.

4. Click OK to close the Formula window.
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De�ine the operation formula for the auto trim part operation
1. Double click the auto trim part opera� on to open the Formula window for that opera� on.

2. In the top panel of the window, enter the following expressions.

Material_weight = Part_weight;

Process_cost = Trim_� me * Trim_process_rate / 3600 / (Overall_plant_effi  ciency / 100);

3. Click Calculate to display the list of variables in the bo� om panel of the window.

De�ine the operation response panel for the auto trim part operation
1. Drag and drop the following variables which will be displayed to the user within the variables lis� ng in the bo� om panel of 

the Formula window so that they are in the order shown at the top of the list.

Trim_process_rate 

Trim_� me

2. For all the remaining variables change Always to Never in the Show to user? column.

3. To complete the variables list, enter the values, units, conversion factors and descrip� ons shown below.

 4. Click OK to close the Formula window.

De�ine the manual trim part operation
1. Copy the auto trim part opera� on by selec� ng Copy from the Edit menu. Paste the opera� on by selec� ng Paste from the 

Edit menu.

2. Rename the second auto trim opera� on to manual trim part by right clicking the opera� on and selec� ng Rename.

De�ine the operation formula and response panel for the manual trim part operation 
1. Double click the manual trim part opera� on to open the Formula window for that opera� on.

2. Change the Value column for the Trim_process_rate variable from 50 to 30.

3. Change the Value column for the Trim_� me variable from 4 to 6.

4. Click OK to close the Formula window

De�ine display conditions and reject rate defaults for operations
1. Click on the preheat workpiece opera� on beneath the Forming process and select Some� mes from the Display opera� on 

dropdown.

2. Click the bu� on near the Condi� on fi eld.
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3. During an analysis, the preheat workpiece opera� on will be displayed on the Process chart whenever the Prehea� ng_
required checkbox is checked on the Main response panel. For this reason, highlight Prehea� ng_required on the le�  and 
type 1 into the Value fi eld on the right.

 4. Click OK and highlight the auto trim part opera� on. Click the Display reject fi eld checkbox that appears on the right. Enter 
0.5 into the Default value for rejects fi eld.

5. Select Some� mes from the Display opera� on dropdown and click the bu� on near the Condi� on fi eld.

6. During an analysis, the auto trim part will be displayed on the Process chart whenever auto is selected from the Type_of_
trimming list on the Main response panel. For this reason, highlight Type_of_trimming on the le�  and type 1 into the Value 
fi eld on the right. Click OK to exit the display condi� ons window.

7. Highlight the manual trim part opera� on and perform the same steps except enter 2 into the Value fi eld when defi ning the 
display condi� ons.

8. Close the Process library by choosing Exit from the File menu.

Link the material library with the Forming process 
1. From the main window of DFM Concurrent Cos� ng, choose Material from the Libraries menu.

2. Expand the Aluminum alloy category.

3. Highlight the AL1100 aluminum, annealed material and click the Forming checkbox that appears on the right.

4. Click the Forming entry that appears beneath the AL1100 aluminum, annealed material and choose AL1100 from the 
Material code name dropdown on the right.

5. Highlight the AL5050 aluminum, annealed material and click the Forming checkbox that appears on the right. Click the 
Forming entry that appears beneath the material and choose AL5050 from the Material code name dropdown on the right.

6. Highlight the AL7075 aluminum, heat treated (T6) material. Choose Material from the Insert menu and a new material is 
added to the library with its name in edit mode. Name the material Duralumin and press the Enter key to accept the name.

7. Click the Forming checkbox on the right and highlight the Forming entry that appears beneath the material. Choose 
Duralumin from the Material code name dropdown on the right.
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8. Close the Material library by choosing Exit from the File menu.

 Removing the imaginary Forming process
1. The Forming process added during this tutorial is completely imaginary and should not be used to analyze real formed 

parts. For this reason, the Forming process should be removed from the Process library a�er the process is created. Open 
the User Process library by choosing it from the Libraries menu on the main screen of the so�ware.

2. Highlight the Forming process and select Delete from the Edit menu. Click OK in the Confirm dialog that appears.

3. Close the User Process library by choosing Exit from the File menu.

4. Open the Material library by choosing it from the Libraries menu.

5. Expand the Aluminum alloy material category and highlight the Duralumin material. Select Delete from the Edit menu and 
click OK in the Confirm dialog that appears.

6. Close the Material library by choosing Exit from the File menu.


